2009-07-19

Eclipse 3.4 3.5 連結 MySQL

首先 Eclipse 必須裝有 DataBase Tool 的套件
再來系統要安裝 JDBC for MySQL 的函示庫

這跟 3.3 的需求不同
函示庫必須安裝在 Java 的目錄下
要不然就會得到以下的錯誤訊息
java.lang.ClassNotFoundException: com.mysql.jdbc.Driver

在 Ubuntu 下你可以使用以下指令安裝
sudo apt-get install libmysql-java

或著到 MySQL 官網下載 mysql-connector-java-5.1.8.tar.gz
然後將 jar 解開至 /usr/share/java 下


看圖說故事
Eclipse MySQL JDBC
在 Eclipse 中建立新連結

Eclipse MySQL JDBC
選取資料庫類型
並填寫連線名稱

Eclipse MySQL JDBC
先建立連結驅動器
之後再填寫這些設定值
要不然也無發測試連線

Eclipse MySQL JDBC
選取資料庫版本

Eclipse MySQL JDBC
這裡要先刪除原有的設定
要不然會出現下面的錯誤訊息
Unable to locate JAR/zip in file system as specified by the driver definition: mysql-connector-java-5.1.0-bin.jar

然後再加入新的連結函示庫

Eclipse MySQL JDBC
函示庫的位址在 /usr/share/java

Eclipse MySQL JDBC
這樣就可以成功建立連結了
再來就是把剩下的設定填一填就好了

之後開啟 Eclipse 後只要在剛建好的連結上執行連接就可以了

參考來源:
Using Eclipse Dali with Hibernate as Persistence Provider

0 回應: